Note: The other languages of the website are Google-translated. Back to English

Como encontrar valor em uma célula com lista separada por vírgulas no Excel?

Supondo que você tenha uma coluna que contém valores separados por vírgula, como Vendas, 123, AAA, e agora você deseja descobrir se o valor 123 na célula separada por vírgula, como pode fazer? Este artigo irá apresentar o método para resolver o problema.

Encontre o valor em uma célula com lista separada por vírgulas com fórmula


Encontre o valor em uma célula com lista separada por vírgulas com fórmula

A fórmula a seguir pode ajudá-lo a encontrar o valor em uma célula com lista separada por vírgulas no Excel. Faça o seguinte.

1. Selecione uma célula em branco, insira a fórmula =IF(ISNUMBER(SEARCH(123,A2)),"yes","no") na barra de fórmulas e pressione a tecla Enter. Veja a imagem:

Nota: na fórmula, A2 é a célula que contém os valores separados por vírgulas que você encontrará.

2. Continue selecionando a célula de resultado e arraste o indicador de preenchimento para baixo para obter todos os resultados. Se o valor “123” estiver nas células separadas por vírgula, você obterá o resultado como “Sim”; caso contrário, você obterá o resultado como “Não”. Veja a imagem:


Artigos relacionados:


As melhores ferramentas de produtividade para escritório

O Kutools for Excel resolve a maioria dos seus problemas e aumenta sua produtividade em 80%

  • armadilha para peixes: Insira rapidamente fórmulas complexas, gráficos e qualquer coisa que você tenha usado antes; Criptografar células com senha; Criar lista de discussão e enviar emails ...
  • Barra Super Fórmula (edite facilmente várias linhas de texto e fórmula); Layout de leitura (ler e editar facilmente um grande número de células); Colar na faixa filtrada...
  • Mesclar células / linhas / colunas sem perder dados; Dividir o conteúdo das células; Combinar linhas / colunas duplicadas... Evite células duplicadas; Comparar intervalos...
  • Selecione Duplicado ou Único Linhas; Selecione linhas em branco (todas as células estão vazias); Super Find e Fuzzy Find em muitos livros; Seleção aleatória ...
  • Cópia exata Várias células sem alterar a referência da fórmula; Criação automática de referências para várias folhas; Inserir marcadores, Caixas de seleção e mais ...
  • Extrair Texto, Adicionar texto, remover por posição, Remover Espaço; Criar e imprimir subtotais de paginação; Converter entre conteúdo de células e comentários...
  • Super Filtro (salvar e aplicar esquemas de filtro a outras planilhas); Classificação Avançada por mês / semana / dia, frequência e mais; Filtro Especial por negrito, itálico ...
  • Combine pastas de trabalho e planilhas; Mesclar tabelas com base em colunas-chave; Divida os dados em várias folhas; Conversão em lote de xls, xlsx e PDF...
  • Mais de 300 recursos poderosos. Suporta Office / Excel 2007-2021 e 365. Suporta todos os idiomas. Fácil implantação em sua empresa ou organização. Recursos completos de avaliação gratuita de 30 dias. Garantia de devolução do dinheiro em 60 dias.
guia kte 201905

Guia do Office traz interface com guias para o Office e torna seu trabalho muito mais fácil

  • Habilite a edição e leitura com guias em Word, Excel, PowerPoint, Publisher, Access, Visio e Project.
  • Abra e crie vários documentos em novas guias da mesma janela, em vez de em novas janelas.
  • Aumenta sua produtividade em 50% e reduz centenas de cliques do mouse para você todos os dias!
parte inferior da aba do escritório
Comentários (16)
Ainda não há classificações. Seja o primeiro a avaliar!
Este comentário foi feito pelo moderador no site
Bom dia a todos.Tenho uma dúvida sobre como contar valores específicos separados por vírgula em uma única célula no excel.Quero contar nenhum de 15 em uma única célula que contenha 15,215,15,155,45,1515,15 resultado 3. Existe alguma fórmula no excel.
Este comentário foi feito pelo moderador no site
Sim, existe uma função no Excel que pode fazer isso para você. No entanto, conforme explicado no problema acima, para obter melhor precisão de seus dados, adicione uma vírgula à esquerda e à direita de sua lista e inclua-a em sua pesquisa. Veja exemplo abaixo:
, 15,215,15,155,45,1515,15,
=CONT.SE(A1, ",15,"")
A explicação desta fórmula é a seguinte: =CONTARSE(número da célula ou intervalo, valor que procura/contagem)
Deixe-me saber se você precisa de um exemplo melhor.
Este comentário foi feito pelo moderador no site
Olá!
Esta é uma fórmula muito legal, mas tem... defeito? ... que não consigo descobrir como contornar isso. "Falha" não é a palavra correta, mas não consigo pensar (são 8h30 na segunda-feira) na palavra certa.
Quando você está procurando por qualquer parte de um número, obtém "sim". Portanto, todos os itens a seguir retornam "sim":
=SE(ISNUMBER(PESQUISA(12,A2)),"sim","não")
=SE(ISNUMBER(PESQUISA(23,A2)),"sim","não")
=SE(ISNUMBER(PESQUISA(3,A2)),"sim","não")

Tentei colocar os números entre aspas sem sucesso. A fórmula funciona perfeitamente para o caso de uso do exemplo, no qual todos os números têm o mesmo comprimento. Mas se você estiver procurando por um número menor que apareça na string, você obterá um falso positivo.
Existe uma alternativa para "PESQUISAR" que seja mais literal (de novo, essa é a palavra? haha)? 
Obrigado! 
Este comentário foi feito pelo moderador no site
Oi Scott S., Você quer dizer pesquisar a string exata?
Este comentário foi feito pelo moderador no site
Olá, Cristal.
Sim, suponho que essa é a maneira de expressá-lo. 
A solução atual retornará “Sim” para qualquer parte da sequência numérica. Portanto, os números 1, 2, 3, 12, 23 e 123 retornarão "Sim". 
Eu tenho tentado encontrar uma solução que pesquise uma sequência de números e retorne "Sim" para uma correspondência exata. 
Este comentário foi feito pelo moderador no site
Olá Scott S, Obrigado pelo seu feedback. Ainda não encontrei a solução e retornarei caso a encontre.
Este comentário foi feito pelo moderador no site
Eu encontrei uma solução para isso. Se você adicionar uma vírgula à esquerda e à direita da sua lista e incluí-los (como um sanduíche) em sua pesquisa, você poderá encontrar uma correspondência exata. Exemplo abaixo:
, 123,231,321,122,321,1,2,3,23,
PESQUISA(",23,"")
Dessa forma, força a pesquisa a corresponder de uma vírgula à outra, em vez de apenas parte da entrada da lista. Espero que isto seja o que você estava procurando?
Este comentário foi feito pelo moderador no site
Eu encontrei uma solução. Se você adicionar uma vírgula à esquerda e à direita de sua lista, será necessário que a função de pesquisa encontre uma correspondência exata de vírgula a vírgula. Veja exemplo abaixo:
=SE(ISNUMBER(PESQUISA(",12",",A2)),"sim","não")

, 312,123,10,112,126,
Isso retornará false porque não há variável de vírgula a vírgula (,12,) que corresponda à pesquisa. 
Se você precisar de mais esclarecimentos, me avise e postarei um exemplo melhor. Eu estava tendo o mesmo problema ao automatizar um relatório para meu chefe e tive uma epifania. :)
Este comentário foi feito pelo moderador no site
Ei, eu ainda não consigo descobrir isso. Eu ainda estou tendo o mesmo problema. em vez de usar o número na fórmula, estou usando uma referência de célula. por exemplo, se eu estiver procurando por "1"(Q$1) em (123, 25,29,200)($J2), ainda está me dando SIM. A fórmula é =SE(ÉNÚMERO(PESQUISAR(Q$1,$J2)),"sim","não")

PS: Tenho um grande conjunto de dados e não consigo colocar vírgulas antes e depois em todas as células. Apreciarei uma solução
Este comentário foi feito pelo moderador no site
Oi por favor ajude

Eu tenho uma tabela no Excel com duas colunas A e B, em A há valor Ex. A2 A célula tem 1,2,2,1,2,1,2 etc (tem apenas dois números 1 e 2, mas precisa reconhecer que tem apenas 1 e 2 na célula inteira e nenhum outro número) e A3 tem 1,1,1 e A4 tem 0, A5 tem 2,2,2,2 e A6 tem 20. eu quero que B2 deve retornar o valor para A2 como Ásia , B3 África, B4 como Nenhum, B5 como América e B6 como Europa. Eu pensei que poderia usar a fórmula if, mas ela não é capaz de reconhecer números separados por vírgula e valor de retorno). Por favor ajude
Este comentário foi feito pelo moderador no site
Que tal isso por favor, preciso pegar os valores em A e igualá-los com as figuras em C e retornar os valores em B separados por vírgulas respectivamente para C.

obrigado
Este comentário foi feito pelo moderador no site
Olá Duncan,
Se você estiver usando o Excel para 365, a fórmula a seguir pode ajudar a resolver o problema.
=TEXTJOIN(",",TRUE,XLOOKUP(TRANSPOSE(VALUE(TEXTSPLIT(D1,","))),A1:A3,B1:B3,"",0,1))
Esta fórmula só funciona no Excel para 365. Para outras versões do Excel além do Excel para 365, não encontrei uma fórmula que a trate.
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/find-value.png
Este comentário foi feito pelo moderador no site
Olá a todos, tenho uma célula que possui vários países separados por vírgulas
Exemplo: o valor da célula A2 é (Índia, Japão, Malásia, Grande China)
A coluna G tem os nomes dos países
Agora, preciso encontrar uma fórmula que compare o valor da coluna G com o valor da célula A2.
Se o valor corresponder, retorne verdadeiro, caso contrário, retorne falso
Este comentário foi feito pelo moderador no site
Olá Mohini Verma,
A fórmula pode ser modificada da seguinte forma:
=SE(ÉNÚMERO(PESQUISAR(G2,A2)),"VERDADEIRO","FALSO")
Este comentário foi feito pelo moderador no site
Ei, eu ainda não consigo descobrir isso. Eu ainda estou tendo o mesmo problema. em vez de usar o número na fórmula, estou usando uma referência de célula. por exemplo, se eu estiver procurando por "1"(Q$1) em (123, 25,29,200)($J2), ainda está me dando SIM. A fórmula é =SE(ÉNÚMERO(PESQUISAR(Q$1,$J2)),"sim","não")

PS: Tenho um grande conjunto de dados e não consigo colocar vírgulas antes e depois em todas as células. Apreciarei uma solução
Este comentário foi feito pelo moderador no site
Oi Hassam

Basta usar a seguinte fórmula sem a função SE. Se o número corresponder exatamente, você obterá o resultado "VERDADEIRO", caso contrário, você obterá o resultado"FALSE".
=NÚMERO(ENCONTRAR(",1,"","&$J2&","))
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/match.png
Não há comentários postados aqui ainda
Deixe o seu comentário
Postando como convidado
×
Avalie esta postagem:
0   Personagens
Locais sugeridos

Siga-nos

Copyright © 2009 - www.extendoffice.com. | Todos os direitos reservados. Distribuído por ExtendOffice. | | | Mapa do site
Microsoft e o logotipo do Office são marcas comerciais ou marcas registradas da Microsoft Corporation nos Estados Unidos e / ou em outros países.
Protegido por Sectigo SSL